En resumen
- CVE-2019-8320 es una vulnerabilidad ALTO (CVSS 7.4) que afecta a rubygems-update, rubygems (rubygems).
- Probabilidad de explotación en los próximos 30 días (EPSS): 4.2%, mayor que el 90.9% de las vulnerabilidades.
- Solución: actualizar a 2.7.9, 3.0.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| rubygems-update RubyGems | ≥ 2.7.6, < 2.7.9≥ 3.0.0, < 3.0.3
| 2.7.93.0.3
|
| rubygems | ≥ 2.7.6, ≤ 3.0.2
| No fix yet |
Description
A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.
NVD description
A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free