En resumen
- CVE-2019-8325 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a rubygems-update, rubygems (rubygems).
- Probabilidad de explotación en los próximos 30 días (EPSS): 3.3%, mayor que el 88.4% de las vulnerabilidades.
- Solución: actualizar a 2.7.9, 3.0.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| rubygems-update RubyGems | ≥ 2.6.0, < 2.7.9≥ 3.0.0, < 3.0.2
| 2.7.93.0.2
|
| rubygems | ≥ 2.6.0, ≤ 3.0.2
| No fix yet |
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)
NVD description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free