En resumen
- CVE-2021-21388 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a systeminformation (systeminformation), systeminformation.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.9%, mayor que el 79.2% de las vulnerabilidades.
- Solución: actualizar a 5.6.4 o posterior.
Description
Impact
command injection vulnerability
Patches
Problem was fixed with a parameter check. Please upgrade to version >= 5.6.4
Workarounds
If you cannot upgrade, be sure to check or sanitize service parameters that are passed to si.inetLatency(), si.inetChecksite(), si.services(), si.processLoad() ... do only allow strings, reject any arrays. String sanitation works as expected.
NVD description
systeminformation is an open source system and OS information library for node.js. A command injection vulnerability has been discovered in versions of systeminformation prior to 5.6.4. The issue has been fixed with a parameter check on user input. Please upgrade to version >= 5.6.4. If you cannot upgrade, be sure to check or sanitize service parameters that are passed to si.inetLatency(), si.inetChecksite(), si.services(), si.processLoad() and other commands. Only allow strings, reject any arrays. String sanitation works as expected.
Más vulnerabilidades de systeminformation
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free