En resumen
- CVE-2022-28366 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a net.sourceforge.htmlunit:neko-htmlunit, antisamy (antisamy project), cyberneko html (cyberneko html project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.2%, mayor que el 82.4% de las vulnerabilidades.
- Solución: actualizar a 2.27, 1.6.6 o posterior.
Description
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24939.
NVD description
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Más vulnerabilidades de net.sourceforge.htmlunit:neko-htmlunit
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free