En resumen
- CVE-2022-37865 es una vulnerabilidad CRÍTICO (CVSS 9.1) que afecta a org.apache.ivy:ivy, ivy (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.9%, mayor que el 79.6% de las vulnerabilidades.
- Solución: actualizar a 2.5.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.ivy:ivy Maven | ≥ 2.4.0, < 2.5.1
| 2.5.1
|
| ivy | ≥ 2.4.0, < 2.5.1
| 2.5.1
|
Description
With Apache Ivy 2.4.0 an optional packaging attribute has been introduced that allows artifacts to be unpacked on the fly if they used
pack200 or zip packaging.
For artifacts using the "zip", "jar" or "war" packaging Ivy prior to version 2.5.1 doesn't verify the target path when extracting the archive. An archive containing absolute paths or paths that try to traverse "upwards" using ".." sequences can then write files to any location on
the local fie system that the user executing Ivy has write access to.
Ivy users of version 2.4.0 to 2.5.0 should upgrade to Ivy version 2.5.1.
NVD description
With Apache Ivy 2.4.0 an optional packaging attribute has been introduced that allows artifacts to be unpacked on the fly if they used pack200 or zip packaging. For artifacts using the "zip", "jar" or "war" packaging Ivy prior to 2.5.1 doesn't verify the target path when extracting the archive. An archive containing absolute paths or paths that try to traverse "upwards" using ".." sequences can then write files to any location on the local fie system that the user executing Ivy has write access to. Ivy users of version 2.4.0 to 2.5.0 should upgrade to Ivy 2.5.1.
Más vulnerabilidades de org.apache.ivy:ivy
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free