En resumen
- CVE-2022-37866 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a org.apache.ivy:ivy, ivy (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.1% de las vulnerabilidades.
- Solución: actualizar a 2.5.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.ivy:ivy Maven | ≥ 2.0.0, < 2.5.1
| 2.5.1
|
| ivy | ≥ 2.0.0, < 2.5.1
| 2.5.1
|
Description
When Apache Ivy downloads artifacts from a repository it stores them in the local file system based on a user-supplied "pattern" that may include placeholders for artifacts coordinates like the organisation, module or version. If said coordinates contain "../" sequences - which are valid characters for Ivy coordinates in general - it is possible the artifacts are stored outside of Ivy's local cache or repository or can overwrite different artifacts inside of the local cache. In order to exploit this vulnerability an attacker needs collaboration by the remote repository as Ivy will issue http requests containing ".." sequences and a "normal" repository will not interpret them as part of the artifact coordinates. Users of Apache Ivy versions 2.0.0 to 2.5.1 should upgrade to Ivy 2.5.1.
NVD description
When Apache Ivy downloads artifacts from a repository it stores them in the local file system based on a user-supplied "pattern" that may include placeholders for artifacts coordinates like the organisation, module or version. If said coordinates contain "../" sequences - which are valid characters for Ivy coordinates in general - it is possible the artifacts are stored outside of Ivy's local cache or repository or can overwrite different artifacts inside of the local cache. In order to exploit this vulnerability an attacker needs collaboration by the remote repository as Ivy will issue http requests containing ".." sequences and a "normal" repository will not interpret them as part of the artifact coordinates. Users of Apache Ivy 2.0.0 to 2.5.1 should upgrade to Ivy 2.5.1.
Más vulnerabilidades de org.apache.ivy:ivy
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free