En resumen
- CVE-2023-22728 es una vulnerabilidad MEDIO (CVSS 4.3) que afecta a silverstripe/framework, framework (silverstripe).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.49%, mayor que el 41.8% de las vulnerabilidades.
- Solución: actualizar a 4.12.5 o posterior.
Description
The GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access.
Upgrade to silverstripe/framework 4.12.5 or above to address the issue.
Reported by Stephan Bauer from relaxt Webdienstleistungsagentur GmbH
NVD description
Silverstripe Framework is the Model-View-Controller framework that powers the Silverstripe content management system. Prior to version 4.12.15, the GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access. Users should upgrade to Silverstripe Framework 4.12.15 or above to address the issue.
Más vulnerabilidades de silverstripe/framework
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free