En resumen
- CVE-2023-41835 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a org.apache.struts:struts2-core, struts (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 7.3%, mayor que el 94.4% de las vulnerabilidades.
- Solución: actualizar a 6.1.2.2, 6.3.0.1, 2.5.32 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.struts:struts2-core Maven | ≥ 6.0.0, < 6.1.2.2≥ 6.2.0, < 6.3.0.1< 2.5.32
| 6.1.2.26.3.0.12.5.32
|
| struts | ≥ 2.0.0, < 2.5.32≥ 6.1.2.1, < 6.3.0.1
| 2.5.326.3.0.1
|
Description
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied.
Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fix this issue.
NVD description
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied.
Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fixe this issue.
Más vulnerabilidades de org.apache.struts:struts2-core
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free