En resumen
- CVE-2024-22207 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a swagger ui (smartbear), @fastify/swagger-ui.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.3%, mayor que el 83.2% de las vulnerabilidades.
- Solución: actualizar a 2.1.0 o posterior.
Description
Impact
The default configuration of @fastify/swagger-ui without baseDir set will lead to all files in the module's directory being exposed via http routes served by the module.
Patches
Update to v2.1.0
Workarounds
Use the baseDir option
References
HackerOne report
.
NVD description
fastify-swagger-ui is a Fastify plugin for serving Swagger UI. Prior to 2.1.0, the default configuration of `@fastify/swagger-ui` without `baseDir` set will lead to all files in the module's directory being exposed via http routes served by the module. The vulnerability is fixed in v2.1.0. Setting the `baseDir` option can also work around this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free