En resumen
- CVE-2024-25637 es una vulnerabilidad MEDIO (CVSS 5.4) que afecta a october/system, october (octobercms).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.26%, mayor que el 18.2% de las vulnerabilidades.
- Solución: actualizar a 3.5.15 o posterior.
| Package | Affected versions | Patched versions |
|---|
| october/system Packagist | ≥ 3.2, < 3.5.15
| 3.5.15
|
| october | ≥ 3.2.0, < 3.5.15
| 3.5.15
|
Description
Impact
The X-October-Request-Handler Header does not sanitize the AJAX handler name and allows unescaped HTML to be reflected back. There is no impact since this vulnerability cannot be exploited through normal browser interactions. This unescaped value is only detectable when using a proxy interception tool.
Patches
This issue has been patched in v3.5.15.
References
Credits to:
For more information
If you have any questions or comments about this advisory:
NVD description
October is a self-hosted CMS platform based on the Laravel PHP Framework. The X-October-Request-Handler Header does not sanitize the AJAX handler name and allows unescaped HTML to be reflected back. There is no impact since this vulnerability cannot be exploited through normal browser interactions. This unescaped value is only detectable when using a proxy interception tool. This issue has been patched in version 3.5.15.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free