En resumen
- CVE-2024-31452 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a github.com/openfga/openfga, openfga (openfga).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.66%, mayor que el 51.4% de las vulnerabilidades.
- Solución: actualizar a 1.5.3 o posterior.
Description
Overview
Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs.
Am I Affected?
You are very likely affected if your model involves exclusion (e.g. a but not b) or intersection (e.g. a and b) and you have any cyclical relationships. If you are using these, please update as soon as possible.
Fix
Update to v1.5.3
Backward Compatibility
This update is backward compatible.
NVD description
OpenFGA is a high-performance and flexible authorization/permission engine. Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs. You are very likely affected if your model involves exclusion (e.g. `a but not b`) or intersection (e.g. `a and b`). This vulnerability is fixed in v1.5.3.
Más vulnerabilidades de github.com/openfga/openfga
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free