En resumen
- CVE-2024-37168 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a @grpc/grpc-js.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.67%, mayor que el 52.1% de las vulnerabilidades.
- Solución: actualizar a 1.10.9, 1.9.15, 1.8.22 o posterior.
| Package | Affected versions | Patched versions |
|---|
| @grpc/grpc-js npm | ≥ 1.10.0, < 1.10.9≥ 1.9.0, < 1.9.15< 1.8.22
| 1.10.91.9.151.8.22
|
Description
Impact
There are two separate code paths in which memory can be allocated per message in excess of the grpc.max_receive_message_length channel option:
- If an incoming message has a size on the wire greater than the configured limit, the entire message is buffered before it is discarded.
- If an incoming message has a size within the limit on the wire but decompresses to a size greater than the limit, the entire message is decompressed into memory, and on the server is not discarded.
Patches
This has been patched in versions 1.10.9, 1.9.15, and 1.8.22
NVD description
@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to versions 1.10.9, 1.9.15, and 1.8.22, there are two separate code paths in which memory can be allocated per message in excess of the `grpc.max_receive_message_length` channel option: If an incoming message has a size on the wire greater than the configured limit, the entire message is buffered before it is discarded; and/or if an incoming message has a size within the limit on the wire but decompresses to a size greater than the limit, the entire message is decompressed into memory, and on the server is not discarded. This has been patched in versions 1.10.9, 1.9.15, and 1.8.22.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free