En resumen
- CVE-2026-48069 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a @grpc/grpc-js.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.88%, mayor que el 59.2% de las vulnerabilidades.
- Solución: actualizar a 1.10.12, 1.11.4, 1.12.7, 1.13.5 o posterior.
| Package | Affected versions | Patched versions |
|---|
| @grpc/grpc-js npm | ≥ 1.10.0, < 1.10.12≥ 1.11.0, < 1.11.4≥ 1.12.0, < 1.12.7≥ 1.13.0, < 1.13.5≥ 1.14.0, < 1.14.4< 1.9.16
| 1.10.121.11.41.12.71.13.51.14.41.9.16
|
Description
Impact
An invalid incoming compressed message can cause a client or server process to crash. This affects all clients and servers that use @grpc/grpc-js
Patches
The following version have fixes for this vulnerability:
- 1.9.16
- 1.10.12
- 1.11.4
- 1.12.7
- 1.13.5
- 1.14.4
Workarounds
There is no workaround.
NVD description
@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming compressed message can cause a client or server process that uses @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free