En resumen
- CVE-2025-27553 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a org.apache.commons:commons-vfs2, commons vfs (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.4%, mayor que el 73.0% de las vulnerabilidades.
- Solución: actualizar a 2.10.0 o posterior.
Description
Relative Path Traversal vulnerability in Apache Commons VFS before 2.10.0.
The FileObject API in Commons VFS has a 'resolveFile' method that
takes a 'scope' parameter. Specifying 'NameScope.DESCENDENT' promises that "an exception is thrown if the resolved file is not a descendent of
the base file". However, when the path contains encoded ".."
characters (for example, "%2E%2E/bar.txt"), it might return file objects that are not
a descendent of the base file, without throwing an exception.
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
NVD description
Relative Path Traversal vulnerability in Apache Commons VFS before 2.10.0.
The FileObject API in Commons VFS has a 'resolveFile' method that
takes a 'scope' parameter. Specifying 'NameScope.DESCENDENT' promises that "an exception is thrown if the resolved file is not a descendent of
the base file". However, when the path contains encoded ".."
characters (for example, "%2E%2E/bar.txt"), it might return file objects that are not
a descendent of the base file, without throwing an exception.
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
Más vulnerabilidades de org.apache.commons:commons-vfs2
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free