En resumen
- CVE-2025-30474 es una vulnerabilidad MEDIO (CVSS 5.0) que afecta a org.apache.commons:commons-vfs2, commons vfs (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.89%, mayor que el 59.4% de las vulnerabilidades.
- Solución: actualizar a 2.10.0 o posterior.
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Commons VFS.
The FtpFileObject class can throw an exception when a file is not found, revealing the original URI in its message, which may include a password. The fix is to mask the password in the exception message
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
NVD description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Commons VFS.
The FtpFileObject class can throw an exception when a file is not found, revealing the original URI in its message, which may include a password. The fix is to mask the password in the exception message
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
Más vulnerabilidades de org.apache.commons:commons-vfs2
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free