En resumen
- CVE-2025-61674 es una vulnerabilidad MEDIO (CVSS 4.8) que afecta a october/system, october (octobercms).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.27%, mayor que el 19.8% de las vulnerabilidades.
- Solución: actualizar a 4.0.12, 3.7.13, 3.17.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| october/system Packagist | ≥ 4.0.0, < 4.0.12< 3.7.13
| 4.0.123.7.13
|
| october | ≥ 4.0.0, < 4.0.12< 3.17.3
| 4.0.123.17.3
|
Description
A cross-site scripting (XSS) vulnerabilities was identified in October CMS backend configuration forms:
- Editor Settings Markup Styles
A user with the Global Editor Settings permission could inject malicious HTML/JS into the stylesheet input at
Settings → Editor Settings → Markup Styles.
A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users.
Impact
- Persistent XSS across the backend interface.
- Exploitable by lower-privileged accounts with the above permissions.
- Potential consequences include privilege escalation, session hijacking, and execution of unauthorized actions in victim sessions.
Patches
The vulnerability has been patched in v4.0.12 and v3.7.13.
Stylesheet inputs are now sanitized to prevent injection of arbitrary HTML/JS.
All users are strongly encouraged to upgrade to the latest patched version.
Workarounds
If upgrading immediately is not possible:
- Restrict the permissions
Global Editor Settings to fully trusted administrators only.
This reduces exposure but does not fully eliminate risk.
Credits
NVD description
October is a Content Management System (CMS) and web platform. Prior to versions 3.7.13 and 4.0.12, a cross-site scripting (XSS) vulnerability was identified in October CMS backend configuration forms. A user with the Global Editor Settings permission could inject malicious HTML/JS into the stylesheet input at Markup Styles. A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users. This issue has been patched in versions 3.7.13 and 4.0.12.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free