En resumen
- CVE-2026-42573 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a svelte (svelte), svelte.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.34%, mayor que el 27.8% de las vulnerabilidades.
- Solución: actualizar a 5.55.7 o posterior.
| Package | Affected versions | Patched versions |
|---|
| svelte | < 5.55.7
| 5.55.7
|
| svelte npm | < 5.55.7
| 5.55.7
|
Description
Svelte was vulnerable to DOM clobbering of its internal framework state on elements, potentially leading to XSS attacks.
You are vulnerable if all of the following is true:
- you are using attribute spreading on a form element
- you are using attribute spreading or allow a dynamic value for the
name attribute on an input or button element within that form
- both of these are simultaneously user-controllable
<form {...spread1}>
<input {...spread2}>
</form>
NVD description
Svelte is a performance oriented web framework. Prior to version 5.55.7, Svelte was vulnerable to DOM clobbering of its internal framework state on elements, potentially leading to XSS attacks. This issue has been patched in version 5.55.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free