En resumen
- CVE-2026-42599 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a svelte (svelte), svelte.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.21%, mayor que el 10.5% de las vulnerabilidades.
- Solución: actualizar a 5.55.7 o posterior.
| Package | Affected versions | Patched versions |
|---|
| svelte | < 5.55.7
| 5.55.7
|
| svelte npm | < 5.55.7
| 5.55.7
|
Description
When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. Note that this vulnerability only triggers if the user's browser has JavaScript enabled but Svelte's hydration mechanism does not reach the vulnerable element before the event fires.
This is similar to but different from CVE-2026-27121.
NVD description
Svelte is a performance oriented web framework. Prior to version 5.55.7, when using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. Note that this vulnerability only triggers if the user's browser has JavaScript enabled but Svelte's hydration mechanism does not reach the vulnerable element before the event fires. This issue has been patched in version 5.55.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free