En resumen
- CVE-2026-43870 es una vulnerabilidad ALTO (CVSS 7.3) que afecta a thrift (apache), thrift.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.38%, mayor que el 31.9% de las vulnerabilidades.
- Solución: actualizar a 0.23.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| thrift | < 0.23.0
| 0.23.0
|
| thrift npm | ≤ 0.22.0
| No fix yet |
Description
Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift.
This issue affects Apache Thrift: before 0.23.0.
Users are recommended to upgrade to version 0.23.0, which fixes the issue.
NVD description
Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift.
This issue affects Apache Thrift: before 0.23.0.
Users are recommended to upgrade to version 0.23.0, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free