En resumen
- CVE-2026-7722 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a prefect.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.45%, mayor que el 39.4% de las vulnerabilidades.
- Solución: actualizar a 3.6.22 o posterior.
| Package | Affected versions | Patched versions |
|---|
| prefect PyPI | < 3.6.22
| 3.6.22
|
Description
A vulnerability was detected in PrefectHQ prefect up to 3.6.21. This impacts the function endswith of the file /api/health of the component Health Check API. Performing a manipulation results in improper authentication. The attack is possible to be carried out remotely. The exploit is now public and may be used. Upgrading to version 3.6.22 will fix this issue. Upgrading the affected component is recommended.
NVD description
A vulnerability was detected in PrefectHQ prefect up to 3.6.21. This impacts the function endswith of the file /api/health of the component Health Check API. Performing a manipulation results in improper authentication. The attack is possible to be carried out remotely. The exploit is now public and may be used. Upgrading to version 3.6.22 will fix this issue. The patch is named e21617125335025b4b27e7d6f0ca028e8e8f3b79. Upgrading the affected component is recommended. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free