En bref
- CVE-2020-15242 est une vulnérabilité MOYENNE (CVSS 6.1) touchant next.js (vercel), next.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.77%, plus élevée que 55.7% des vulnérabilités.
- Correctif : mettre à jour vers 9.5.4 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 9.5.0, < 9.5.4
| 9.5.4
|
| next npm | ≥ 9.5.0, < 9.5.4
| 9.5.4
|
Description
NVD description
Next.js versions >=9.5.0 and <9.5.4 are vulnerable to an Open Redirect. Specially encoded paths could be used with the trailing slash redirect to allow an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attackers domain from a trusted domain. The issue is fixed in version 9.5.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free