En bref
- CVE-2021-29625 est une vulnérabilité MOYENNE (CVSS 6.1) touchant vrana/adminer, adminer (adminer).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 9.6%, plus élevée que 95.5% des vulnérabilités.
- Correctif : mettre à jour vers 4.8.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| vrana/adminer Packagist | ≥ 4.7.8, < 4.8.1
| 4.8.1
|
| adminer | ≥ 4.6.1, < 4.8.1
| 4.8.1
|
Description
Impact
Users of MySQL, MariaDB, PgSQL and SQLite are affected. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a pdo_ extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected.
Patches
Patched by 4043092, included in version 4.8.1.
Workarounds
Do both:
- Use browser supporting strict CSP.
- Enable the native PHP extensions (e.g.
mysqli) or disable displaying PHP errors (display_errors).
References
https://sourceforge.net/p/adminer/bugs-and-features/797/
For more information
If you have any questions or comments about this advisory:
NVD description
Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free