En bref
- CVE-2021-32923 est une vulnérabilité ÉLEVÉE (CVSS 7.4) touchant github.com/hashicorp/vault, vault (hashicorp).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.4%, plus élevée que 72.1% des vulnérabilités.
- Correctif : mettre à jour vers 1.5.9, 1.6.5, 1.7.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 0.10.0, < 1.5.9≥ 1.6.0, < 1.6.5≥ 1.7.0, < 1.7.2
| 1.5.91.6.51.7.2
|
| vault | ≥ 0.10.0, < 1.5.9≥ 1.6.0, < 1.6.5≥ 1.7.0, < 1.7.2
| 1.5.91.6.51.7.2
|
Description
HashiCorp Vault and Vault Enterprise allowed the renewal of nearly-expired token leases and dynamic secret leases (specifically, those within 1 second of their maximum TTL), which caused them to be incorrectly treated as non-expiring during subsequent use. Fixed in 1.5.9, 1.6.5, and 1.7.2.
NVD description
HashiCorp Vault and Vault Enterprise allowed the renewal of nearly-expired token leases and dynamic secret leases (specifically, those within 1 second of their maximum TTL), which caused them to be incorrectly treated as non-expiring during subsequent use. Fixed in 1.5.9, 1.6.5, and 1.7.2.
Autres vulnérabilités de github.com/hashicorp/vault
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free