En bref
- CVE-2026-3605 est une vulnérabilité ÉLEVÉE (CVSS 8.1) touchant github.com/hashicorp/vault, vault (hashicorp).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.38%, plus élevée que 31.7% des vulnérabilités.
- Correctif : mettre à jour vers 1.19.16, 2.0.0, 1.20.10, 1.21.5 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 0.10.0, ≤ 1.21.4≥ 0.10.0
| No fix yet |
| vault | ≥ 0.10.0, < 1.19.16≥ 0.10.0, < 2.0.0≥ 1.20.0, < 1.20.10≥ 1.21.0, < 1.21.5
| 1.19.162.0.01.20.101.21.5
|
Description
An authenticated user with access to a kvv2 path through a policy containing a glob may be able to delete secrets they were not authorized to read or write, resulting in denial-of-service. This vulnerability did not allow a malicious user to delete secrets across namespaces, nor read any secret data. Fixed in Vault Community Edition 2.0.0 and Vault Enterprise 2.0.0, 1.21.5, 1.20.10, and 1.19.16.
NVD description
An authenticated user with access to a kvv2 path through a policy containing a glob may be able to delete secrets they were not authorized to read or write, resulting in denial-of-service. This vulnerability did not allow a malicious user to delete secrets across namespaces, nor read any secret data. Fxed in Vault Community Edition 2.0.0 and Vault Enterprise 2.0.0, 1.21.5, 1.20.10, and 1.19.16.
Autres vulnérabilités de github.com/hashicorp/vault
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free