En bref
- CVE-2025-11621 est une vulnérabilité ÉLEVÉE (CVSS 8.1) touchant github.com/hashicorp/vault, vault (hashicorp).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.49%, plus élevée que 42.1% des vulnérabilités.
- Correctif : mettre à jour vers 1.21.0, 1.16.27, 1.19.11, 1.20.5 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 0.6.0, < 1.21.0
| 1.21.0
|
| vault | ≥ 0.6.0, < 1.16.27≥ 0.6.0, < 1.21.0≥ 1.18.0, ≤ 1.18.15≥ 1.19.0, < 1.19.11≥ 1.20.0, < 1.20.5
| 1.16.271.21.01.19.111.20.5
|
Description
Vault and Vault Enterprise's ("Vault") AWS Auth method may be susceptible to authentication bypass if the role of the configured bound_principal_iam is the same across AWS accounts, or uses a wildcard. This vulnerability is fixed in Vault Community Edition 1.21.0 and Vault Enterprise 1.21.0, 1.20.5, 1.19.11, and 1.16.27.
NVD description
Vault and Vault Enterprise’s (“Vault”) AWS Auth method may be susceptible to authentication bypass if the role of the configured bound_principal_iam is the same across AWS accounts, or uses a wildcard. This vulnerability, CVE-2025-11621, is fixed in Vault Community Edition 1.21.0 and Vault Enterprise 1.21.0, 1.20.5, 1.19.11, and 1.16.27
Autres vulnérabilités de github.com/hashicorp/vault
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free