En bref
- CVE-2021-37404 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant org.apache.hadoop:hadoop-common, hadoop (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 3.0%, plus élevée que 87.3% des vulnérabilités.
- Correctif : mettre à jour vers 3.2.3, 3.3.2, 2.10.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.hadoop:hadoop-common Maven | ≥ 3.0.0, < 3.2.3≥ 3.3.0, < 3.3.2< 2.10.2
| 3.2.33.3.22.10.2
|
| hadoop | ≥ 2.9.0, < 2.10.2≥ 3.0.0, ≤ 3.1.4≥ 3.2.0, < 3.2.3≥ 3.3.0, < 3.3.2
| 2.10.23.2.33.3.2
|
Description
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
NVD description
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Autres vulnérabilités de org.apache.hadoop:hadoop-common
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free