En bref
- CVE-2022-25168 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant org.apache.hadoop:hadoop-common, hadoop (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 4.6%, plus élevée que 91.6% des vulnérabilités.
- Correctif : mettre à jour vers 2.10.2, 3.2.4, 3.3.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.hadoop:hadoop-common Maven | ≥ 2.0.0, < 2.10.2≥ 3.0.0-alpha, < 3.2.4≥ 3.3.0, < 3.3.3
| 2.10.23.2.43.3.3
|
| hadoop | ≥ 2.0.0, ≤ 2.10.1≥ 3.0.0, ≤ 3.2.3≥ 3.3.0, ≤ 3.3.2
| No fix yet |
Description
Apache Hadoop's FileUtil.unTar(File, File) API does not escape the input file name before being passed to the shell. An attacker can inject arbitrary commands. This is only used in Hadoop 3.3 InMemoryAliasMap.completeBootstrapTransfer, which is only ever run by a local user. It has been used in Hadoop 2.x for yarn localization, which does enable remote code execution. It is used in Apache Spark, from the SQL command ADD ARCHIVE. As the ADD ARCHIVE command adds new binaries to the classpath, being able to execute shell scripts does not confer new permissions to the caller. SPARK-38305. "Check existence of file before untarring/zipping", which is included in 3.3.0, 3.1.4, 3.2.2, prevents shell commands being executed, regardless of which version of the hadoop libraries are in use. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.3 or upper (including HADOOP-18136).
NVD description
Apache Hadoop's FileUtil.unTar(File, File) API does not escape the input file name before being passed to the shell. An attacker can inject arbitrary commands. This is only used in Hadoop 3.3 InMemoryAliasMap.completeBootstrapTransfer, which is only ever run by a local user. It has been used in Hadoop 2.x for yarn localization, which does enable remote code execution. It is used in Apache Spark, from the SQL command ADD ARCHIVE. As the ADD ARCHIVE command adds new binaries to the classpath, being able to execute shell scripts does not confer new permissions to the caller. SPARK-38305. "Check existence of file before untarring/zipping", which is included in 3.3.0, 3.1.4, 3.2.2, prevents shell commands being executed, regardless of which version of the hadoop libraries are in use. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.3 or upper (including HADOOP-18136).
Autres vulnérabilités de org.apache.hadoop:hadoop-common
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free