En bref
- CVE-2021-37699 est une vulnérabilité MOYENNE (CVSS 6.1) touchant next.js (vercel), next.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.0%, plus élevée que 63.8% des vulnérabilités.
- Correctif : mettre à jour vers 11.1.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 10.0.5, ≤ 10.2.0≥ 11.0.0, ≤ 11.0.1
| No fix yet |
| next npm | ≥ 0.9.9, < 11.1.0
| 11.1.0
|
Description
Next.js is an open source website development framework to be used with the React library. In affected versions specially encoded paths could be used when pages/_error.js was statically generated, allowing an open redirect to occur to an external site. In general, this redirect does not directly harm users although it can allow for phishing attacks by redirecting to an attacker's domain from a trusted domain.
Impact
- Affected: Users of Next.js between
10.0.5 and 10.2.0
- Affected: Users of Next.js between
11.0.0 and 11.0.1 using pages/_error.js without getInitialProps
- Affected: Users of Next.js between
11.0.0 and 11.0.1 using pages/_error.js and next export
- Not affected: Deployments on Vercel (vercel.com) are not affected
- Not affected: Deployments with
pages/404.js
- Note that versions prior to 0.9.9 package
next npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions.
We recommend upgrading to the latest version of Next.js to improve the overall security of your application.
Patches
https://github.com/vercel/next.js/releases/tag/v11.1.0
NVD description
Next.js is an open source website development framework to be used with the React library. In affected versions specially encoded paths could be used when pages/_error.js was statically generated allowing an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attacker's domain from a trusted domain. We recommend everyone to upgrade regardless of whether you can reproduce the issue or not. The issue has been patched in release 11.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free