En bref
- CVE-2023-4680 est une vulnérabilité MOYENNE (CVSS 6.8) touchant github.com/hashicorp/vault, vault (hashicorp).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.44%, plus élevée que 38.2% des vulnérabilités.
- Correctif : mettre à jour vers 1.13.7, 1.14.3, 1.12.11 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 1.13.0, < 1.13.7≥ 1.14.0, < 1.14.3≥ 1.6.0, < 1.12.11
| 1.13.71.14.31.12.11
|
| vault | ≥ 1.13.0, < 1.13.7≥ 1.14.0, < 1.14.3≥ 1.6.0, < 1.12.11
| 1.13.71.14.31.12.11
|
Description
HashiCorp Vault and Vault Enterprise transit secrets engine allowed authorized users to specify arbitrary nonces, even with convergent encryption disabled. The encrypt endpoint, in combination with an offline attack, could be used to decrypt arbitrary ciphertext and potentially derive the authentication subkey when using transit secrets engine without convergent encryption. Introduced in 1.6.0 and fixed in 1.14.3, 1.13.7, and 1.12.11.
NVD description
HashiCorp Vault and Vault Enterprise transit secrets engine allowed authorized users to specify arbitrary nonces, even with convergent encryption disabled. The encrypt endpoint, in combination with an offline attack, could be used to decrypt arbitrary ciphertext and potentially derive the authentication subkey when using transit secrets engine without convergent encryption. Introduced in 1.6.0 and fixed in 1.14.3, 1.13.7, and 1.12.11.
Autres vulnérabilités de github.com/hashicorp/vault
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free