En bref
- CVE-2025-14986 est une vulnérabilité FAIBLE (CVSS 1.3) touchant go.temporal.io/server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.43%, plus élevée que 37.1% des vulnérabilités.
- Correctif : mettre à jour vers 1.27.4, 1.28.2, 1.29.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| go.temporal.io/server Go | ≥ 1.24.0, < 1.27.4≥ 1.28.0, < 1.28.2≥ 1.29.0, < 1.29.2
| 1.27.41.28.21.29.2
|
Description
When frontend.enableExecuteMultiOperation is enabled, the server can apply namespace-scoped validation and feature gates for the embedded StartWorkflowExecutionRequest using its Namespace field rather than the outer, authorized ExecuteMultiOperationRequest.Namespace. This allows a caller authorized for one namespace to bypass that namespace's limits/policies by setting the embedded start request's namespace to a different namespace. The workflow is still created in the outer (authorized) namespace; only validation/gating is performed under the wrong namespace context.
This issue affects Temporal: from 1.24.0 through 1.29.1. Fixed in 1.27.4, 1.28.2, 1.29.2.
NVD description
When frontend.enableExecuteMultiOperation is enabled, the server can apply namespace-scoped validation and feature gates for the embedded StartWorkflowExecutionRequest using its Namespace field rather than the outer, authorized ExecuteMultiOperationRequest.Namespace. This allows a caller authorized for one namespace to bypass that namespace's limits/policies by setting the embedded start request's namespace to a different namespace. The workflow is still created in the outer (authorized) namespace; only validation/gating is performed under the wrong namespace context.
This issue affects Temporal: from 1.24.0 through 1.29.1. Fixed in 1.27.4, 1.28.2, 1.29.2.
Autres vulnérabilités de go.temporal.io/server
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free