| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.cassandra:cassandra-all | ≥ 3.1, < 3.11.18≥ 4.0-alpha1, < 4.0.16≥ 4.1-alpha1, < 4.1.8≥ 5.0-alpha1, < 5.0.3< 3.0.31 | 3.11.184.0.164.1.85.0.33.0.31 |
| cassandra | ≥ 3.0.0, < 3.0.31≥ 3.1, < 3.11.18≥ 4.0.0, < 4.0.16≥ 4.1.0, < 4.1.8≥ 5.0.0, < 5.0.3 | 3.0.313.11.184.0.164.1.85.0.3 |
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.
This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2.
Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free