En bref
- CVE-2025-27553 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant org.apache.commons:commons-vfs2, commons vfs (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.4%, plus élevée que 73.0% des vulnérabilités.
- Correctif : mettre à jour vers 2.10.0 ou plus récent.
Description
Relative Path Traversal vulnerability in Apache Commons VFS before 2.10.0.
The FileObject API in Commons VFS has a 'resolveFile' method that
takes a 'scope' parameter. Specifying 'NameScope.DESCENDENT' promises that "an exception is thrown if the resolved file is not a descendent of
the base file". However, when the path contains encoded ".."
characters (for example, "%2E%2E/bar.txt"), it might return file objects that are not
a descendent of the base file, without throwing an exception.
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
NVD description
Relative Path Traversal vulnerability in Apache Commons VFS before 2.10.0.
The FileObject API in Commons VFS has a 'resolveFile' method that
takes a 'scope' parameter. Specifying 'NameScope.DESCENDENT' promises that "an exception is thrown if the resolved file is not a descendent of
the base file". However, when the path contains encoded ".."
characters (for example, "%2E%2E/bar.txt"), it might return file objects that are not
a descendent of the base file, without throwing an exception.
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
Autres vulnérabilités de org.apache.commons:commons-vfs2
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free