En bref
- CVE-2025-30474 est une vulnérabilité MOYENNE (CVSS 5.0) touchant org.apache.commons:commons-vfs2, commons vfs (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.89%, plus élevée que 59.4% des vulnérabilités.
- Correctif : mettre à jour vers 2.10.0 ou plus récent.
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Commons VFS.
The FtpFileObject class can throw an exception when a file is not found, revealing the original URI in its message, which may include a password. The fix is to mask the password in the exception message
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
NVD description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Commons VFS.
The FtpFileObject class can throw an exception when a file is not found, revealing the original URI in its message, which may include a password. The fix is to mask the password in the exception message
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
Autres vulnérabilités de org.apache.commons:commons-vfs2
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free