En bref
- CVE-2025-46762 est une vulnérabilité ÉLEVÉE (CVSS 8.1) touchant org.apache.parquet:parquet-avro, parquet (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.6%, plus élevée que 75.7% des vulnérabilités.
- Correctif : mettre à jour vers 1.15.2 ou plus récent.
Description
Schema parsing in the parquet-avro module of Apache Parquet 1.15.0 and previous versions allows bad actors to execute arbitrary code.
While 1.15.1 introduced a fix to restrict untrusted packages, the default setting of trusted packages still allows malicious classes from these packages to be executed.
The exploit is only applicable if the client code of parquet-avro uses the "specific" or the "reflect" models deliberately for reading Parquet files. ("generic" model is not impacted)
Users are recommended to upgrade to 1.15.2 or set the system property "org.apache.parquet.avro.SERIALIZABLE_PACKAGES" to an empty string on 1.15.1. Both are sufficient to fix the issue.
NVD description
Schema parsing in the parquet-avro module of Apache Parquet 1.15.0 and previous versions allows bad actors to execute arbitrary code.
While 1.15.1 introduced a fix to restrict untrusted packages, the default setting of trusted packages still allows malicious classes from these packages to be executed.
The exploit is only applicable if the client code of parquet-avro uses the "specific" or the "reflect" models deliberately for reading Parquet files. ("generic" model is not impacted)
Users are recommended to upgrade to 1.15.2 or set the system property "org.apache.parquet.avro.SERIALIZABLE_PACKAGES" to an empty string on 1.15.1. Both are sufficient to fix the issue.
Autres vulnérabilités de org.apache.parquet:parquet-avro
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free