En bref
- CVE-2025-47951 est une vulnérabilité MOYENNE (CVSS 4.9) touchant weblate, weblate (weblate).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.27%, plus élevée que 18.5% des vulnérabilités.
- Correctif : mettre à jour vers 5.12 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.12
| 5.12
|
| weblate | < 5.12
| 5.12
|
Description
Impact
The verification of the second factor was not subject to rate limiting. The absence of rate limiting on the second factor endpoint allows an attacker with valid credentials to automate OTP guessing.
Patches
This issue has been addressed in Weblate 5.12 via https://github.com/WeblateOrg/weblate/pull/14918.
References
Thanks to obscuredeer for reporting this issue at HackerOne.
NVD description
Weblate is a web based localization tool. Prior to version 5.12, the verification of the second factor was not subject to rate limiting. The absence of rate limiting on the second factor endpoint allows an attacker with valid credentials to automate OTP guessing. This issue has been patched in version 5.12.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free