En bref
- CVE-2025-48387 est une vulnérabilité ÉLEVÉE (CVSS 8.7) touchant tar-fs.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.58%, plus élevée que 47.9% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.3, 3.0.9, 1.16.5 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| tar-fs npm | ≥ 2.0.0, < 2.1.3≥ 3.0.0, < 3.0.9< 1.16.5
| 2.1.33.0.91.16.5
|
Description
Impact
v3.0.8, v2.1.2, v1.16.4 and below
Patches
Has been patched in 3.0.9, 2.1.3, and 1.16.5
Workarounds
You can use the ignore option to ignore non files/directories.
ignore (_, header) {
// pass files & directories, ignore e.g. symlinks
return header.type !== 'file' && header.type !== 'directory'
}
Credit
Thank you Caleb Brown from Google Open Source Security Team for reporting this in detail.
NVD description
tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.0.9, 2.1.3, and 1.16.5 have an issue where an extract can write outside the specified dir with a specific tarball. This has been patched in versions 3.0.9, 2.1.3, and 1.16.5. As a workaround, use the ignore option to ignore non files/directories.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free