En bref
- CVE-2025-59343 est une vulnérabilité ÉLEVÉE (CVSS 8.7) touchant tar-fs.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.58%, plus élevée que 48.0% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.4, 3.1.1, 1.16.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| tar-fs npm | ≥ 2.0.0, < 2.1.4≥ 3.0.0, < 3.1.1< 1.16.6
| 2.1.43.1.11.16.6
|
Description
Impact
v3.1.0, v2.1.3, v1.16.5 and below
Patches
Has been patched in 3.1.1, 2.1.4, and 1.16.6
Workarounds
You can use the ignore option to ignore non files/directories.
ignore (_, header) {
// pass files & directories, ignore e.g. symlinks
return header.type !== 'file' && header.type !== 'directory'
}
Credit
Reported by: Mapta / BugBunny_ai
NVD description
tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.1.1, 2.1.3, and 1.16.5 are vulnerable to symlink validation bypass if the destination directory is predictable with a specific tarball. This issue has been patched in version 3.1.1, 2.1.4, and 1.16.6. A workaround involves using the ignore option on non files/directories.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free