En bref
- CVE-2025-55173 est une vulnérabilité MOYENNE (CVSS 4.3) touchant next.js (vercel), next.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.60%, plus élevée que 48.7% des vulnérabilités.
- Correctif : mettre à jour vers 15.4.5, 14.2.31 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 15.0.0, < 15.4.5< 14.2.31
| 15.4.514.2.31
|
| next npm | ≥ 0.9.9, < 14.2.31≥ 15.0.0, < 15.4.5
| 14.2.3115.4.5
|
Description
A vulnerability in Next.js Image Optimization has been fixed in v15.4.5 and v14.2.31. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery.
All users relying on images.domains or images.remotePatterns are encouraged to upgrade and verify that external image sources are strictly validated.
More details at Vercel Changelog
NVD description
Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free