En bref
- CVE-2025-59471 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant next.js (vercel), next.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.49%, plus élevée que 41.9% des vulnérabilités.
- Correctif : mettre à jour vers 15.5.10, 16.1.5 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 10.0.0, < 15.5.10≥ 16.0.0, < 16.1.5
| 15.5.1016.1.5
|
| next npm | ≥ 10.0.0, < 15.5.10≥ 15.6.0-canary.0, < 16.1.5
| 15.5.1016.1.5
|
Description
A DoS vulnerability exists in self-hosted Next.js applications that have remotePatterns configured for the Image Optimizer. The image optimization endpoint (/_next/image) loads external images entirely into memory without enforcing a maximum size limit, allowing an attacker to cause out-of-memory conditions by requesting optimization of arbitrarily large images. This vulnerability requires that remotePatterns is configured to allow image optimization from external domains and that the attacker can serve or control a large image on an allowed domain.
Strongly consider upgrading to 15.5.10 and 16.1.5 to reduce risk and prevent availability issues in Next applications.
NVD description
A denial of service vulnerability exists in self-hosted Next.js applications that have `remotePatterns` configured for the Image Optimizer. The image optimization endpoint (`/_next/image`) loads external images entirely into memory without enforcing a maximum size limit, allowing an attacker to cause out-of-memory conditions by requesting optimization of arbitrarily large images. This vulnerability requires that `remotePatterns` is configured to allow image optimization from external domains and that the attacker can serve or control a large image on an allowed domain.
Strongly consider upgrading to 15.5.10 or 16.1.5 to reduce risk and prevent availability issues in Next applications.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free