En bref
- CVE-2025-5999 est une vulnérabilité ÉLEVÉE (CVSS 7.2) touchant github.com/hashicorp/vault, vault (hashicorp).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.51%, plus élevée que 43.6% des vulnérabilités.
- Correctif : mettre à jour vers 1.20.0, 1.16.22, 1.18.11, 1.19.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 0.10.4, < 1.20.0
| 1.20.0
|
| vault | ≥ 0.10.4, < 1.16.22≥ 0.10.4, < 1.20.0≥ 1.17.0, < 1.18.11≥ 1.19.0, < 1.19.6
| 1.16.221.20.01.18.111.19.6
|
Description
A privileged Vault operator with write permissions to the root namespace’s identity endpoint could escalate their own or another user’s token privileges to Vault’s root policy. Fixed in Vault Community Edition 1.20.0 and Vault Enterprise 1.20.0, 1.19.6, 1.18.11 and 1.16.22.
NVD description
A privileged Vault operator with write permissions to the root namespace’s identity endpoint could escalate their own or another user’s token privileges to Vault’s root policy. Fixed in Vault Community Edition 1.20.0 and Vault Enterprise 1.20.0, 1.19.6, 1.18.11 and 1.16.22.
Autres vulnérabilités de github.com/hashicorp/vault
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free