En bref
- CVE-2025-6203 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant github.com/hashicorp/vault, vault (hashicorp).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.73%, plus élevée que 54.4% des vulnérabilités.
- Correctif : mettre à jour vers 1.20.3, 1.16.27, 1.21.0, 1.18.15 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | < 1.20.3
| 1.20.3
|
| vault | ≥ 1.15.0, < 1.16.27≥ 1.15.0, < 1.21.0≥ 1.18.0, < 1.18.15≥ 1.19.0, < 1.19.11≥ 1.20.0, < 1.20.5
| 1.16.271.21.01.18.151.19.111.20.5
|
Description
A malicious user may submit a specially-crafted complex payload that otherwise meets the default request size limit which results in excessive memory and CPU consumption of Vault. This may lead to a timeout in Vault’s auditing subroutine, potentially resulting in the Vault server to become unresponsive. This vulnerability, CVE-2025-6203, is fixed in Vault Community Edition 1.20.3 and Vault Enterprise 1.20.3, 1.19.9, 1.18.14, and 1.16.25.
NVD description
A malicious user may submit a specially-crafted complex payload that otherwise meets the default request size limit which results in excessive memory and CPU consumption of Vault. This may lead to a timeout in Vault’s auditing subroutine, potentially resulting in the Vault server to become unresponsive. This vulnerability, CVE-2025-6203, is fixed in Vault Community Edition 1.20.3 and Vault Enterprise 1.20.3, 1.19.9, 1.18.14, and 1.16.25.
Autres vulnérabilités de github.com/hashicorp/vault
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free