En bref
- CVE-2026-103004 est une vulnérabilité MOYENNE (CVSS 5.3) touchant next.js (vercel), next.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.25%, plus élevée que 16.4% des vulnérabilités.
- Correctif : mettre à jour vers 16.3.8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 16.3.0, < 16.3.8
| 16.3.8
|
| next npm | ≥ 16.3.0, < 16.3.8
| 16.3.8
|
Description
Impact
With Cache Components enabled (cacheComponents: true), a 'use cache' function that calls another 'use cache' function that reads a root param can be keyed incorrectly when the inner call is served from an existing entry: the enclosing function's cache key then omits that root param. The enclosing entry is written once and reused for all root param values, so a response for one root param value can serve content produced for a different value — whether the page is prerendered at build time or at runtime, or rendered dynamically. Shared cache headers let downstream caches redistribute the content further.
What values are leaked cannot be attacker controlled. Which value's content is served depends only on which invocation wrote the entry first.
Workarounds
There are no known workarounds. Apps should upgrade to the patched version as soon as possible.
NVD description
Next.js versions from 16.3.0 to 16.3.7 warm `use cache` handlers using `next/root-params` and can leak their return value to pages with different root params. With Cache Components enabled (cacheComponents: true), a 'use cache' function that calls another 'use cache' function that reads a root param can be keyed incorrectly when the inner call is served from an existing entry: the enclosing function's cache key then omits that root param. The enclosing entry is written once and reused for all root param values, so a response for one root param value can serve content produced for a different value — whether the page is prerendered at build time or at runtime, or rendered dynamically. Shared cache headers let downstream caches redistribute the content further.
What values are leaked cannot be attacker controlled. Which value's content is served depends only on which invocation wrote the entry first.
This has been patched in 16.3.8.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free