En bref
- CVE-2026-106559 est une vulnérabilité MOYENNE (CVSS 6.5) touchant backstage (linuxfoundation), backstage/plugin-scaffolder-backend-module-confluence-to-markdown (linuxfoundation), @backstage/plugin-scaffolder-backend-module-confluence-to-markdown.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.33%, plus élevée que 26.4% des vulnérabilités.
- Correctif : mettre à jour vers 1.54.6, 0.3.25 ou plus récent.
Description
Impact
Insufficient input validation in the Confluence to Markdown scaffolder module could allow an attacker to influence file write operations during template execution. Exploitation requires a Backstage user to run a template that processes attacker-influenced Confluence content.
Patches
Patched in @backstage/plugin-scaffolder-backend-module-confluence-to-markdown version 0.3.25
Workarounds
If unable to update immediately:
- Restrict Confluence edit access to trusted users.
- Review Confluence page content before running scaffolder templates against untrusted pages.
NVD description
Backstage is an open framework for building developer portals. Prior to 0.3.25, the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package is affected by improper input validation in confluence to markdown scaffolder module. Insufficient input validation in the Confluence to Markdown scaffolder module could allow an attacker to influence file write operations during template execution. Exploitation requires a Backstage user to run a template that processes attacker-influenced Confluence content. This issue is fixed in version 0.3.25.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free