En bref
- CVE-2026-106563 est une vulnérabilité MOYENNE (CVSS 6.5) touchant backstage (linuxfoundation), backstage/plugin-kubernetes-backend (linuxfoundation), @backstage/plugin-kubernetes-backend.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.22%, plus élevée que 13.2% des vulnérabilités.
- Correctif : mettre à jour vers 1.54.1, 0.21.8 ou plus récent.
Description
Impact
An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters.
Patches
Patched in @backstage/plugin-kubernetes-backend version 0.21.8.
Workarounds
- Disable the deprecated
/services/:serviceId route by deploying a custom Kubernetes router that omits it.
- Restrict access to the
kubernetes.resources.read permission to limit the set of users who can reach the endpoint.
NVD description
Backstage is an open framework for building developer portals. Prior to 0.21.8, the @backstage/plugin-kubernetes-backend package is affected by improper entity validation in deprecated kubernetes services endpoint. An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. This issue is fixed in version 0.21.8.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free