En bref
- CVE-2026-40563 est une vulnérabilité ÉLEVÉE (CVSS 8.1) touchant org.apache.atlas:apache-atlas, atlas (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.46%, plus élevée que 40.2% des vulnérabilités.
- Correctif : mettre à jour vers 2.5.0 ou plus récent.
Description
Description:
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Atlas.
Apache Atlas exposes a DSL search endpoint that accepts user-supplied query strings. Attacker can alter Gremlin traversal logic within grammar-allowed characters to access unintended data.
Affected Version:
This issue affects Apache Atlas: from 0.8-incubating through 2.4.0.
For affected versions >= 2.0.0, the vulnerability is only exploitable when Atlas is deployed with below non-default configuration.
atlas.dsl.executor.traversal=false
Mitigation:
Users are recommended to upgrade to version 2.5.0, which fixes the issue.
NVD description
Description:
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Atlas
Apache Atlas exposes a DSL search endpoint that accepts user-supplied query strings. Attacker can alter Gremlin traversal logic within grammar-allowed characters to access unintended data
Affect Version:
This issue affects Apache Atlas: from 0.8 through 2.4.0.
For the affect version >= 2.0, vulnerability is only when Atlas is deployed with below non-default configuration.
atlas.dsl.executor.traversal=false
Mitigation:
Users are recommended to upgrade to version 2.5.0, which fixes the issue.
Autres vulnérabilités de org.apache.atlas:apache-atlas
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free