En bref
- CVE-2026-45109 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant next.js (vercel), next.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.60%, plus élevée que 48.8% des vulnérabilités.
- Correctif : mettre à jour vers 15.5.18, 16.2.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 15.2.0, < 15.5.18≥ 16.0.0, < 16.2.6
| 15.5.1816.2.6
|
| next npm | ≥ 15.2.0, < 15.5.18≥ 16.0.0, < 16.2.6
| 15.5.1816.2.6
|
Description
Impact
It was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. Refer to CVE-2026-44575 for further details.
References
NVD description
Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and 16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. This vulnerability is fixed in 15.5.18 and 16.2.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free