En bref
- CVE-2026-56745 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant io.netty:netty-codec-http, netty (netty).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.63%, plus élevée que 50.2% des vulnérabilités.
- Correctif : mettre à jour vers 4.1.136.Final, 4.2.16.Final, 4.1.136, 4.2.16 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| io.netty:netty-codec-http Maven | ≥ 4.1.0.Final, < 4.1.136.Final≥ 4.2.0.Final, < 4.2.16.Final
| 4.1.136.Final4.2.16.Final
|
| netty | ≥ 4.1.0, < 4.1.136≥ 4.2.0, < 4.2.16
| 4.1.1364.2.16
|
Description
The SpdyHttpDecoder handler in Netty's SPDY-to-HTTP codec allocates a pooled ByteBuf when processing a client-initiated SYN_STREAM frame with FLAG_FIN=0, storing the partially-constructed FullHttpRequest in an internal map (messageMap) to accumulate subsequent DATA frames. When the remote peer sends an RST_STREAM for that stream, or when the accumulated content exceeds maxContentLength, the decoder removes the entry from the map but never releases the pooled ByteBuf, permanently leaking the allocated memory.
NVD description
Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and 4.1.0.Final through 4.1.135.Final, the `SpdyHttpDecoder` handler in Netty's SPDY-to-HTTP codec allocates a pooled `ByteBuf` when processing a client-initiated `SYN_STREAM` frame with `FLAG_FIN=0` and stores the partially constructed `FullHttpRequest` in `messageMap`; when the remote peer sends `RST_STREAM` for that stream or the accumulated content exceeds `maxContentLength`, the decoder removes the entry but does not release the pooled `ByteBuf`, causing native memory exhaustion. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
Autres vulnérabilités de io.netty:netty-codec-http
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free