En bref
- CVE-2026-59898 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant io.netty:netty-codec-http, netty (netty).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.44%, plus élevée que 38.2% des vulnérabilités.
- Correctif : mettre à jour vers 4.2.16.Final, 4.1.136.Final, 4.2.16, 4.1.136 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| io.netty:netty-codec-http Maven | ≥ 4.2.0.Final, < 4.2.16.Final< 4.1.136.Final
| 4.2.16.Final4.1.136.Final
|
| netty | ≥ 4.2.0, < 4.2.16< 4.1.136
| 4.2.164.1.136
|
Description
Summary
An attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending Sec-WebSocket-Version: 7 and omitting Connection: Upgrade / Upgrade: websocket headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks.
NVD description
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Autres vulnérabilités de io.netty:netty-codec-http
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free