En bref
- CVE-2026-62280 est une vulnérabilité MOYENNE (CVSS 6.1) touchant org.openidentityplatform.openam:openam-oauth2.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.33%, plus élevée que 25.8% des vulnérabilités.
- Correctif : mettre à jour vers 16.1.2 ou plus récent.
Description
Description
The OAuth2/OIDC consent page rendered for display=wap authorize requests reflected several request-derived values into the HTML response without escaping. An attacker who induces a user with an active OpenAM session to follow a crafted authorize link can execute arbitrary JavaScript in the OpenAM origin.
This is the same vulnerability class as CVE-2026-44203; that fix did not cover this code path.
Impact
Arbitrary JavaScript execution in the OpenAM origin in the victim's authenticated context — enabling session/cookie theft, CSRF-token exfiltration, and actions on behalf of the victim, up to administrative takeover if the victim is an administrator. Reachable on any deployment with at least one registered OAuth2 client; no attacker-controlled client and no special configuration required.
Mitigation
- Upgrade to 16.1.2 (or later).
- Until then, restrict/limit access to the OAuth2 authorize endpoint and treat unsolicited
display=wap authorize links as untrusted.
NVD description
Open Access Management (OpenAM) is an access management solution. From 13.0.0 until 16.1.2, the OAuth2 authorize endpoint's display=wap consent page reflects request-derived values through ConsentRequiredResource and wap/authorize.ftl without HTML escaping. An attacker can induce a user with an active OpenAM session to follow a crafted authorization link and execute JavaScript in the OpenAM origin, enabling session or cookie theft, CSRF-token disclosure, and actions with the victim's privileges. At least one registered OAuth2 client is required, but the attacker does not need to control that client. This issue is fixed in version 16.1.2.
Autres vulnérabilités de org.openidentityplatform.openam:openam-oauth2
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free