En bref
- CVE-2026-64646 est une vulnérabilité MOYENNE (CVSS 5.3) touchant next.js (vercel), next.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.52%, plus élevée que 44.4% des vulnérabilités.
- Correctif : mettre à jour vers 15.5.21, 16.2.11 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 13.0.0, < 15.5.21≥ 16.0.0, < 16.2.11
| 15.5.2116.2.11
|
| next npm | ≥ 13.0.0, < 15.5.21≥ 16.0.0, < 16.2.11
| 15.5.2116.2.11
|
Description
Impact
Requests targeting Next.js applications using App Router with at least one Server Action can lead to excessive memory consumption if that Server Actions uses the Edge runtime
Workarounds
If you cannot upgrade, ensure your hosting provider limits the request's body size. 5 MiB should be allowed at max by your hosting provider.
NVD description
Next.js is a React framework for building full-stack web applications. In versions 13.0.0 through 15.5.20 and 16.0.0 through 16.2.10, requests targeting Next.js applications using App Router with at least one Server Action can lead to excessive memory consumption if that Server Actions uses the Edge runtime. This issue has been fixed in versions 15.5.21 and 16.2.11.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free